WP theme change resulting in 404 errors


Hi everyone,

At present I’m using a free theme ‘Blue Planet’. I recently moved my blogger blog to WP and tried a couple of themes before settling on ‘Blue Planet’ free theme for now.

The problem I recently found is, whenever I change back to the old theme after trying a new, there’s always a 404 error messages from a deleted themes’ URL. Why is it happening? Also I want to know if changing theme always results in errors?



First this forum related to Blogger and most of Support guys are experts on Blogger platform.

In your Case maybe URL format change with every theme choosen. It may overcome configuring Using Permalinks « WordPress Codex https://codex.wordpress.org/Using_Permalinks


Yes Rohan informed me of that. I just couldn’t delete the post. Seems like there’s no option to do so. However, Thank you for providing the link to solve my problem unrelated to Blogger. :smile:


Hi priya, I would have loved to answer that question but it does not relate to any of our category. But you are always welcome to ask us for any web hosting, SEO or Design related to questions because these categories are platform independent. :innocent:


changing themes does not make any error, i personally did thrice before setelling to sahifa,

so problem lies some where else.

did that link worked?


Hi Mohammad,

Thank you. & I will stay on the topic. :smile:


Hi @The_Next_Rex

I guessed as much but broken link plugin keep finding them. Yes when I check those links they do show a 404 error. Maybe it has something do to with the fact that i changed the permalink setting recently and it didn’t go smoothly. Also before that I hadn’t installed broken link checker so not sure if the problem was already there.

For now I’m not changing themes to prevent these errors.


i dont think that will resolve your problem, i am not an expert, just using wordpress 24/7 since this past four months.

i guess the problem is as u stated changing permalink, but changing theme will use the same setting, i dont think it wil fix,

try sahifa theme its good clean and nice, avada ( its full of options, one get confused some thing )

do let me knw if the problem is solved and what exactly u did to solve it,


You were right. Got one more 404 error. :smiley: Anyways, here’s what I have done for now, since the site is up and running maybe the trick worked.


1.Saved permalink settings in Settings again; same one that was there before.

  1. Opened FTC alongside Yoast .htaccess file. Checked both files and saved. (Also checked if there’s another .htaccess file in FTC.)

3.Have changed the theme for testing.

Now the wait is on.

One more 404 error because of the theme change and I’m done making changes I barely understand. Simply going to buy a premium one and move to that one for a long time. At least till I start having some understanding of coding, which now I think is a must. Time to learn.


well see, in my opinion ( as i m not an expert with 10 years experience) the problem is, your old posts/pages have some different permalink, for example it was www.priya.com/how-to-blog and u changed it to www.priya.com/1056 or something else. and when you try to open www.priya.com/how-to-blog it gives u 404 error, since you have the address has been changed to www.priya.com/1056 . i would suggest, come on skype screen share, with me or any one , take an opinion, may be the problem is small. so it will save you money,

there is a find and replace link plugin avilable, but that is mostly used for shifting sites. for example www.priya.com to www.priyasharma.com so address of all posts will be changed accordingly and youu wont see any 404 error. but i guess thats not the case here


Yes, I have moved the blog from blogger to WP, so yes, link structure was different and now is different too. And problems started only after changing permalink structure. Actually, I used to get 404 errors a day or two after changing to a new theme.

Happy to report, it’s almost a week and so far haven’t got any new 404 errors (have changed themes just to check), indicating that it’s resulting from theme change. So I guessing, issue has been resolved. :smile:

Thank you @The_Next_Rex for offering to help and helping by discussing the issue. :smile:


pleasure, i hope your problem is solved and wont happen again.

so the bottom line is, it was the permalink that were troubling you?