Multiple meta tag title and description found In blogger blog


#1

I am using Mozbar to check the status of a blogger blog or website. But when, I check my website, then error occurring of multiple meta description and title found. And google webmaster too.

I have almost followed all tactics or solutions of Mybloggertricks. But nothing could be happened. I have,

  1. Disabled mobile view of template,

  2. Added the following tag in blogger head

        <b:if cond='data:blog.url != data:blog.homepageUrl'> 
        <b:if cond='data:blog.pageType != &quot;item&quot;'> 
        <b:if cond='data:blog.metaDescription != &quot;&quot;'> 
        <meta expr:content='data:blog.metaDescription' name='description'/> 
         </b:if> 
         </b:if> 
         </b:if>
    
  3. Modified Robot.txt, see below,

                      Disallow: /?m=0
                      Disallow: /?m=1
    

And, Mozbar and google webmaster tool continuously showing ‘multiple meta description and title found’.

I know only Mustafa Sir can solve this problem. Please sir, I am waiting for your response.


#2

Please Refer to this topic . Whenever you are about to post a topic please search it before so that you might find a relevant topic or same topic for help.


#3

@Nafees, As i said. I have already followed some solutions. But failed. Please analyse my blog source code and find what is the problems. Blog address= http://www.hugestreet.info . And, if Mustafa sir watching this topic.then please sir, help me to solve this problem.

I am facing this problem from the last few months


#5

IF you have applied My Blogger Tricks Codes… Then it Will Work…It takes time for Google To reload Again… So Keep calm and Sit front of Computer watching BHF


#6

Or You can Referr to this topic and Try Some of Mine Codes "too same "

Click Here


#7

@VishalChopra You are using an old code, I have updated it after Google introduced more support for conditional tags. Please add these codes in your blog and give it a weak for google to update its web index data of your site.

Note: Do resubmit your sitemap after making this change.

  1. Go To Blogger > Template > Click the Gear Icon under Mobile and choose

No. Show desktop template on mobile devices.

  1. Now go inside your template and find and delete this code or similar:

This will fix the /?m=0 and /?m=1 errors. When you disable Mobile view, the above code still remains inside your template which you dont want. Although it is related to viewport but this is something which we dont need either.

CC: @junaid_juni try the above method and remove this code and inform me if your errors are gone.

  1. Next Add these codes just below <head> inside your template

    <b:if cond=‘data:blog.pageType != “index”’> <b:if cond=‘data:blog.pageType != “item” and data:blog.pageType != “static_page”’> <b:if cond=‘data:blog.metaDescription != “”’> </b:if> </b:if> </b:if>

    <b:if cond=‘data:blog.pageType == “archive”’> </b:if>

  2. In your webmaster account, switch all URL parameters to “Let Google bot decide” default options. Don’t make any change here

  3. Disable Robots.txt and X Robots Header tags from Blogger > Settings > Search preferences.

Come back after a weak or 10 days and let me know if you got rid of these errors. :thumbsup:


#8

Mohammad, I am not using any description tag in my blog but descriptions are appearing perfectly! How?


#9

Not all templates require it and there are different ways to add it. It is often needed by custom templates which are of old origin Version 1. New blogger templates are built on class=‘v2’


#10

I tried above method but then I check my website in Google Mobile Friently and found that is not friently any more…is that right?


#11

Kindly explain in more detail what you mean @Nick

MBT has all the above code and its Mobile Interface score is 100%


#12

@Mohammad, @Nick

Thanks, Mustafa sir,

Now, MozBar is not showing any errors.

But after disable mobile view, my blogger blog is now not mobile friendly. click here to see


#13

Ok Mohammad,

First I disable mobile template and then I delete this code from my template

 <meta content='width=device-width, initial-scale=1, maximum-scale=1' name='viewport'/> 
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>

Then I followed the steps from #3

If I follow above steps ,my teplate is no more friently .Please reply.


#14

Re-add:

<meta content='width=device-width, initial-scale=1, maximum-scale=1' name='viewport'/> 

and then try. Your template will become mobile friendly again.


#15

I agree but Mohammad tutorial says to delete this code or similiar

<meta content='IE=EmulateIE7' http-equiv='X-UA-Compatible'/>
    <b:if cond='data:blog.isMobile'>
   <meta content='width=device-width,initial-scale=1.0,minimum-scale=1.0,maximum-scale=1.0' name='viewport'/>
    <b:else/>
      <meta content='width=1100' name='viewport'/>
    </b:if>

#16

Mohammad said:

and in this, <meta content='width=device-width,initial-scale=1.0,minimum-scale=1.0,maximum-scale=1.0' name='viewport'/> was under <b:if cond='data:blog.isMobile'>.

If you found that meta under <b:if cond='data:blog.isMobile'>, then remove it only.


#17

@vector I add meta code but still non friently

https://www.google.com/webmasters/tools/mobile-friendly/?url=http%3A%2F%2Fwww.ntsotsos.gr%2F


#18

So its your blog template fault. Because this code > <meta content='width=device-width,initial-scale=1.0,minimum-scale=1.0,maximum-scale=1.0' name='viewport'/> only load CSS media queries. It not make your template mobile friendly.


#19

What I have to do to fix it please? Should I start new template?


#20

Well, you can make your existing template mobile friendly using some hard work and tweaks but if you don’t want to do hard work, then you can choose a different template for your blog. But this time, make sure that the template you are going to choose is good looking, mobile friendly, and fast loading. Good Luck! :+1:


#21

I create a new test template and apply Mohammad tips again without any modification in template. Again template is not friently…template is not custom.

https://www.google.com/webmasters/tools/mobile-friendly/?url=http%3A%2F%2Ftest-ntsotsos.blogspot.gr%2F