How to Remove Duplicate Meta Descriptions in GWT Under HTML Improvements?


#1

Hi everyone, Its my second question in this forum, As the title shows the exact problem that I face. The problem is I’m facing some Duplicate Meta Descriptions errors for blogger posts. These errors appeared 4 or more months ago and until they’re here to decrease site’s traffic. The number of errors will continues decreasing and increasing and it never comes under 8 and never goes up than 24. Now currently 10 errors as appearing in picture below:

I’ve many various actions to get them out but its a badluck that they still there.

Action #1:

Added these meta tags inside header tag in blogger HTML to block access to m=1 and m=0 links

<b:if cond='data:blog.isMobile'>
<meta content='noindex, nofollow' name='robots'/>
</b:if>

Action #2:

Block m=1 and m=0 based URL’s through Robots.txt

User-agent: Mediapartners-Google
Disallow: 

User-agent: *
Disallow: /search
Disallow: /?m=0
Disallow: /?m=1
Disallow: /*m=0
Disallow: /*m=1
Allow: /

Action #3:

Added m based parameter under URL Parameters section of Google Webmaster Tools to handle mobile based URL’s:

Are you think that any more action is required to get these errors out from my house :smile: If yes than share action # 4: end so on.


#2

I’m also having this problem in one of my blogs. I didn’t know that this will also affect my traffic. Please help if anyone know the solution. I teried removing my self added meta tag discription in the template but nothing happened.


#3

Raja these are mobile parameters that are inserted when users search your blog using web search. Blogger applies this parameter for both desktop and mobile views. The best way to get rid of them is to disable the Mobile view option from template section. Once the mobile view is deactivated the browser will stop redirecting mobile traffic to ?m=1 and it will instead load your responsive stylesheet.

You will need to create responsive style for different screen sizes in order to better help your site rank well because Google now throws more traffic to sites which are mobile responsive.

Also read my post on responsive stylesheet here:

Also revert your robots.txt back to default and remove that noindex meta tag for mobile view because you don’t need it. Read this post for better understanding of what i mean


#4

Thanks brother for help and reply… I follow your steps with removing:

<b:if cond='data:blog.isMobile'>
<meta content='noindex, nofollow' name='robots'/>
</b:if>

it from head tags… Revert the robot.txt file to default. Ad this tagline into head section as well.

<meta content='width=device-width, initial-scale=1, maximum-scale=1' name='viewport'/>

My mobile template view was disabled previously… Thanks again


#5

That is great now! Let google update its cache and make the new changes. Kindly create the responsive stylesheet soon. The meta viewport tag only enables CSS3 media queries to be inserted, since you have added that, now you need to customize the site layout to fit into different mobile devices. I will write a detailed tutorial soon on how to do it


#7

The duplicate meta description drops from 10 to 4 in last Google parameter update on 12/03/2015. But suddenly all the 10 errors appeared again in this last update on 16/03/2015.

Now after yesterday update the # of errors are now 10 which is similar value showing in question asked 8 days ago.

So the problem is still there. So do you’ve anymore solution ? @Mohammad


#8

@Mr_Raja Give me your site url so I can try to help you


#9

here is the URL: http://www.urgentfiles.com/


#10

@Mr_Raja Search for the this code

     <b:if cond='data:blog.metaDescription != &quot;&quot;'>
  <meta expr:content='data:blog.metaDescription' name='description'/>
</b:if>

and replace these codes with the following codes:

 <b:if cond='data:blog.url != data:blog.homepageUrl'>
<b:if cond='data:blog.pageType != &quot;item&quot;'>
<b:if cond='data:blog.metaDescription != &quot;&quot;'>
  <meta expr:content='data:blog.metaDescription' name='description'/>
</b:if>
</b:if>
</b:if>

If your issue is still not resolved then inform me …


#11

Please delete your account @AmmarAli: because its not 2013, Its 2015 now Google gives:

and you give me that 2+ years old data from MBT,


#12

@Mr_Raja Try This Method:

Open “Custom robots header tags” section and mark all as shown in the screenshot

Save it .and then check the errors.


#13

You’re going against @Mohammad’s tutorials: So confirm it first then advise me:

source: http://www.mybloggertricks.com/2013/09/recover-your-blog-lost-traffic-due-to.html


#16

Well @Mr_Raja, Don’t take it as Advertisement. But You can check here about robot header tags: (Point 3)

http://bloggerguiders.blogspot.com/2015/03/best-tactics-to-get-higher-rankings-for.html

#17

Thanks for your time @Shivansh: see this pic below then guide me…

Follow these tutorials on your site first and then advise me later :sunglasses:


#18

Well, @Mr_Raja, My site is new and only 6 days old. :smile: Well, Wait for some days and you will see instant decrease in alexa rank. :smile:

And I don’t believe in Alexa and I think, the people who saw alexa for measuring site’s goodness are fool.

Quoting Here Mohammad:

I also know quick ways to decrease alexa rank like Alexa boostup, Place a alexa widget in blog, giving some dofollow link in some posts. But I don’t believe in Alexa.

Well, I have told you the way by which you can get better ranking and solve your problem. But If you don’t want then simply ignore that. I think you should thankful to peoples that help you and you are doing opposite with @AmmarAli, me and also with @Mohammad. Mohammad has also warned you for your this behavior.

And when we talk about your and my blog, my blog is better. I have not written many articles but they all are 500+ words and quality post. Your blog’s template is not responsive