[FIXED] Blogger's 'Don't Track your own pageviews' Not Working


#1

Hey guys are you also having the same error, When i try to enable the option “Don’t Track Your own Page Views” on the blogger dashboard then i get the error notice. Like on the image below.

I searched every where on the internet but couldn’t found the solution.

So anyone can help?


#2

What happened when you re-loaded and tried again?


#3

I am getting same error every time i reload and try again.

Many people are facing the same problem. I tried to search on other forums also but couldn’t found any solution.


#4

I’ve also been facing this error for long. But,this error doesn’t occur in Mozilla Firefox. Maybe some technical issues related with Google Chrome.


#5

@souravsudhi It not working in Mozilla also.


#6

@shahsantosh Me also causing the same problem … I think that error is on Blogspot side not on our side


#7

@MUHSIN_MOHAMED_PC Yes it has been a long time this type of error showing up. Why blogger is not fixing it?


#8

@shahsantosh I don’t know … Now i don’t care about it because Blogger showing lot of hits . So i just using the Statcounter for Analyzing my Hits .


#9

It’s a common problem and no ‘don not track your own pageviews’ option never works. I tried a lot last year. As per this article I found (Issue with "Don’t track your own pageviews) you need to add a code to your browser. And still it won’t fix the problem completely. Read the ‘note’ in the end. So I abandoned the idea of fixing the problem.


#10

I strongly believe this could be a browser error not from google.

Change the browser or update it and Try. also may be caused due to slow internet.


#11

Friends, Now that feature is working fine. Update Your Google Chrome and see.

As You Can See In Picture:

Thanks!


#12

Hi guys

I have exactly the same issue; I have tried both Mozilla and Chrome…same error message…tried reloading but nothing changes

Any other ideas?

Thanks G


#13

Hmm…I don’t know how it is working for me. It never shows my visits on Stats.


#14

Hello,

I’ve tried it on chrome, the feature didn’t work… tried it on Microsoft edge (the new browser from windows 10) and it worked perfectly :smiley:

hope this helps

regards :smile:


#15

hi, Shivansh ‘Don’t Track your own pageviews’ work only blogger subdomain. custom domain use - www.yourdomain.com/b/statsBlockingCookie?action=SET&callback=gwt_jsonp.P2.onSuccess


#16

Hi , you use Custom domain so you use this link - www.yourdomain.com/b/statsBlockingCookie?action=SET&callback=gwt_jsonp.P2.onSuccess

Replace yourdomain.com put your own domain name .


#17

@Esobondhu_com, thanks for sharing that URL. I have researched about it and posted how to work with that script.

Please don’t take it as a advertisement or promotion.

Stop Any Blogspot Blog From Tracking Your Own Pageviews

I hope you will get sufficient information about that URL. You can block other blogs too with that URL and there is an option for removing cookie files too by replacing SET to UNSET.


#18

So, if this is the issue, how can I make my own blogger site stop tracking my computer?

  1. Open a new tab on your browser while you’re still logged in
  2. Copy the text below and paste it on the address bar of the new tab www.yourdomain.com/b/statsBlockingCookie?action=SET&callback=gwt_jsonp.P2.onSuccess
  3. Replace “yourdomain.com” to your domain name
  4. Press “Enter” and a response should be shown like below // API callback gwt_jsonp.P2.onSuccess({“status”:“yes”});
  5. Go to your home page and keep reloading the page. You will find that the pageviews counter stop incrementing (the counter is either on your home page or the dashboard).

#19

This is a old post where I am posting but why you are focusing on blogger page views, these stats are crap. Kindly focus on Google Analytics most reliable source of your websites/blog traffic


#20

Thank you very much Shashank_Singh. This fix worked for me.