Duplicate Meta Descriptions For Mobile and Desktop Views [HTML Improvements]



Q1- My GWT shows me duplicate content for desktop and mobile site. almost every site is running both, but do they not get the GWT warning for duplicate content? mybloggertricks.com and its mobile site mybloggertricks.com?m=1 or m=0 all are running without restriction from robot.txt but dont you have such GWT problem in your account? How can i solve this? how did you handle for your blog brother?

i have read it everywhere that google is smart enough to recognize both the sites, but if they then why i m having GWT issues, they should not show me there as both are for different devices despite the mobile link can be opened in desktop but it should know that its for mobile. m.skysports and skysports are another example that can be seen on the search results of google from desktop.

Q2- now another is about adsense, since the google bot is telling me of above duplicate content, then adbot will also do the same (i.e consider both as duplicate content), then the duplicate content will ban me from adsense, isnt it?

My domain is www.footballnewsguru.com


How to Remove Duplicate Meta Descriptions in GWT Under HTML Improvements?

W.salam dear affandi, I did a quick review of your site and found that the site is mobile responsive by default and the other thing that I found quite strange was your custom robots.txt file as shown below:

User-agent: Mediapartners-Google Disallow: 
User-agent: * 
Disallow: /search 
Allow: / Disallow: /*?m 
Disallow: /*?showComment 
Sitemap: http://www.footballnewsguru.com/feeds/posts/default?orderby=UPDATED

robots.txt file uses two key words, User-agent and Disallow and where Allow is just a child of Disallow command and often they are considered as a single entry.

User-agent: Mediapartners-Google Disallow: 

You have written user-agent and Disallow keywords in a single line which is a bad practice and surely robots treat them different because the keywords have no delimeters that may tell the robot where the command ends and instead we use a New Line to indicate a break line and tell the robot that the command ends after each line-break.

Further you have written a wrong syntax for disabling the mobile view

Allow: / Disallow: /*?m 

Adding a parent and child keywords in a single entry is surely not a standard practice.

In simple words you have a wrongly setup robots.txt file which you must optimize by following the tips shared below:

  1. Go To Blogger > Settings > Search Preferences
  2. Disable Custom Robots.txt
  3. Hit Save
  4. You may also configure the X-Robots Header tags as shown below:

After making this change your new robots.txt file located at http://www.footballnewsguru.com/robots.txt must look like the one shared below:

User-agent: Mediapartners-Google

User-agent: *
Disallow: /search
Allow: /

Sitemap: http://www.footballnewsguru.com/sitemap.xml

Submit your new sitemap to google http://www.footballnewsguru.com/sitemap.xml

Disable Mobile View

Since your blog has is responsive by default so you don’t need the blogger mobile view template and disable it if you have not

  1. Go To Blogger > Template
  2. Click the “Gear” icon under Mobile
  3. Choose "No. Show desktop template on mobile devices."
  4. Save

Duplicate Meta Description

I wrote a detailed tutorial on Blogger’s bug which caused multiple descriptions for homepage and posts and proposed a solution. Though your blog is currently configured in this case but I want you to re-check if your code matches the one I shared below:

   <b:if cond='data:blog.url != data:blog.homepageUrl'>
      <b:if cond='data:blog.pageType != &quot;item&quot;'>
        <b:if cond='data:blog.metaDescription != &quot;&quot;'>
          <meta expr:content='data:blog.metaDescription' name='description'/>

Give it a 3-5 days and see if things changed for you. Also share the screenshots of the errors GWT is showing you.


Thanks but still confused. The thing you told me is already done. i cant see a block code for mobile links from your end for mbt and since u r running means u r not having duplicate problems in GWT, why is this so?

For robot.txt i know the single line problems and that allow disallow one, that was mistakenly done few days ago else i was showing the right one after checking it from GWT.

User-agent: Mediapartners-Google  


User-agent: *  

Allow: /

Disallow: /search 

Disallow: /*?m  

Disallow: /*?showComment  

Sitemap: http://www.footballnewsguru.com/feeds/posts/default?orderby=UPDATED

this was the actual working code which has been running for the past few months.

and secondly the code u want me to add is already there.

THESE SAME THINGS I HAVE DONE TO CHECK MYSELF BECAUSE i ASK QUESTION AFTER DOING EVERY POSSIBILITY. this will surely give me copied content(duplicate description plus title) among normal link and with m-0 m=1. thats why i blocked this from the robot.txt (ignore the wrong commands)

and last one disabling the mobile template wont work too. and i have activated it because of the widgets as i dont want to show on mobile.

The simple thing is that dont you see the duplicate errors for mobile and desktop links in GWT? if no then why this problem is for me only :frowning:

and the last question is still left to be answered. Adsene one. I hope i can get free from these worries asap.


simple is how to stop GWT for showing me mobile and desktop links as copied content.

This is a simple question. I have done your method before so i know that will show me again.

and the last question is still left to be answered. Adsene one. www.mybloggertricks.com and www.mybloggertricks.com?m=1 or even mybloggertricks.com?m=0 all are showing adsense then wont they think all the ads are running on the pages with same content (duplicate content).


Kindly do me one favour, attach screenshots of the errors shown by webmaster tools and share all screenshots so that I may know what exactly is being pointed out.

As far as activating the mobile view is concerned , you may better disable is again, widgets do not bother a lot as much the mobile view offered by blogger which surely messes up the custom AD zones and ad revenue.

Yes you are right we have never encountered these errors for mbt in our webmaster tools account The problem with you could be easily solved if you share the screenshots so that I may know exactly what the errors are all about

Will AdSense Ban you for sharing Duplicate Content

The answer is a big NO! AdSense team works independently from the webspam team leaded by matt cutts. They manually check a site for sharing duplicate content before banning it. In your case it is the URL parameter for mobile i.e. ( ?m=1 and ?m=0)that is causing all the trouble. These parameters are just a query passed through your DNS and they never pose a risk of duplicate content because blogger uses the rel=‘canonical’ attribute which points all URLS back to the root domain itself. So you must be fully convinced there is no risk of content here.

URL parameters are added sometimes by third-party services like AdSense and Analytics and sometimes by Blogger itself. 3rd party Services add it for tracking purposes and Blogger adds it for sorting purpose. You must make sure you have chosen the option of “Let Googlebot decide” for all the URL parameters that appear in your GWT account. You don’t need to edit them because Google can easily distinguished the parameters inserted by services it owns so no work required on your part. Just set them to default.

Popular URL parameters found in Blogger Blogs

  • m
  • utm_source
  • utm_medium
  • utm_campaign
  • showComment
  • commentPage
  • max-results

Waiting for the screenshots


Thank you so much thats what i was looking for, and will share the screen shots once it shows me up again.



You are always welcomed affandi. Screenshots help a lot in understanding the problem better and as far as I think you just need to fix the URL parameters and the robots.txt file and you will certainly have everything fixed.


This can now be seen mate. these are the problems i always face regarding mobile site both m=1 and m=0 and also the links for showcomment etc.

Now tell me what to do? i removed these errors through robot.txt but since you are not facing these then whats the problem?


How to Fix ?m=1 or ?m=0 issues in google crawl

Dear, Create a new topic and paste the same question. So It will also help other members. :smile:


The information on Custom Robots.txt is useful and not found in most tutorials on Custom Robots.txt, most Bloggers still follow the earlier tutorials.


I did some research on your case and found that most of the template which are using JSON API to load content have this issue by default. A common approach adopted by most of these templates is a custom script which fetches information about the name, version and platform of the browser using the userAgent property

The code looks like this one

<script type="text/javascript">
var a = "indexOf",
    b = "&m=1",
    e = "(^|&)m=",
    f = "?",
    g = "?m=1";

function h() {
    var c = window.location.href,
        d = c.split(f);
    switch (d.length) {
        case 1:
            return c + g;
        case 2:
            return 0 <= d[1].search(e) ? null : c + b;
            return null
var k = navigator.userAgent;
if (-1 != k[a]("Mobile") && -1 != k[a]("WebKit") && -1 == k[a]("iPad") || -1 != k[a]("Opera Mini") || -1 != k[a]("IEMobile")) {
    var l = h();
    l && window.location.replace(l)

As a programmer yourself, you can clearly see that the script is detecting m=1 parameter inside the href and the moment it detects it, it replaces it with the windows actual location which is your root domain. Which means that it will permanently redirect all mobile URLs back to your root URL thus eliminating the chances of all duplicate content issues because the browser now serves only the actual version of your content to both readers and robots.

The Dilemma

Your template has the code by default but it does not seem to be functioning as it is intended to do. We did recently developed some templates using the jSON API but We have never used this script because we don’t think that after disabling the Mobile layout, you need any custom script to force the action. Therefore I would suggest that you delete this code from your template which could be the only reason why robots are not able to pick the correct version of your HREF parameters

Find and delete this code from your template

<script type="text/javascript">var a="indexOf",b="&m=1",e="(^|&)m=",f="?",g="?m=1";function h(){var c=window.location.href,d=c.split(f);switch(d.length){case 1:return c+g;case 2:return 0<=d[1].search(e)?null:c+b;default:return null}}var k=navigator.userAgent;if(-1!=k[a]("Mobile")&&-1!=k[a]("WebKit")&&-1==k[a]("iPad")||-1!=k[a]("Opera Mini")||-1!=k[a]("IEMobile")){var l=h();l&&window.location.replace(l)};

Give it sometime and see if the HTML improvements issue is fixed once and for all!


Thank you. First the code was there only because of the mobile template was not disabled, now i have disabled it and the code is not there anymore. The mobile version was enabled because of some widgets, i dont want some of the widgets on the mobile version thats why.

And the last thing is that my previous template also showed me the same problems, and for that template the mobile version was never been enabled. You can see my test blog for the previous version http://fng-test-blog.blogspot.com/ it doesnot have that code as the mobile version is disabled since the start.

I dont think that this will solve the issue since the robot.txt is also fetching such showcomment urls which are not related to mobile links or templates.


Why did you remove that code from robots.txt if it was working properly?

Install this custom robots.txt file on your blog

User-agent: Mediapartners-Google  


User-agent: *  

Allow: /

Disallow: /search 

Disallow: /*?m  

Disallow: /*?showComment  

Sitemap: http://www.footballnewsguru.com/sitemap.xml

I have tested the above robots.txt file and it is well configured

Also delete that script from your site and also disable blogger mobile view. That custom script is not inserted by blogger because I don’t see it being inserted automatically on any of my templates where I disable the Mobile view.


I removed it because that was the method i created and never seen on any site or blog, thats why i was confused with it.

And the second thing the code only comes when mobile template is enabled even when it it of blogger. This is from blogger as i can see on http://fng-test-blog.blogspot.com/ these codes are generated by blogger when mobile template is enabled.

Anyways thanks still could not know why i am facing such issue only. i will block them as i did in the past from robot.txt.

Thanks for your time and patience. :slight_smile:


Kindly add the robots.txt file I shared above which is similar to the one you were using and get back here, informing us if this solved your problem.

The robots.txt file is best solution for you after we have tried all other methods. And never loose hope, keep asking because your case study can help thousand others going through the same problems. :innocent: