Drop down menu not working in main site( urgent help) please


#1

hello there!

from yesterday on wards all of sudden, this site’s [address][1] drop down menu stopped working!

when i upload that site’s template to a testing blog, it is working there, but not in main site [address][1]

i checked the drop down menu code, all is well then why it is not working fine?

help needed urgently @Shivansh

thanks in advance [1]: http://www.sourcemasters.co.in


#2

It could be because of multiple jQuery plugins.

Firstly, remove this code which is present two times in your blog. Remove both of them.

<script data-rocketsrc='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js' type="text/rocketscript"></script>

Now, below <head>, add this code and save your template and inform me if it got started working:

<script src='http://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.1/jquery.min.js' type='text/javascript'></script>

#3

they are not in my template.

they are running at runtime it think from cloudflare server


#4

Hm… I am unable to understand that what you are saying but it looks like my solution has worked for you.

Have a great day!


#5

Yes @SamaraSsr @Shivansh was right go blog editor line no 2795 or your side arrow check it

or your can simple find

function authorshow(data)

below that your find this code, Don’t use cloudflare cdn of Jquery

Replace

<script src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js'/>

With this

    <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js" type="text/javascript"></script>
    <script type="text/javascript">
    //<![CDATA[
   window.jQuery || document.write('<script src="path/to/your/jquery"><\/script>')
    //]]>
    </script>

#6

this is all because of rocket loader which is at cloudflare server!

when i turn it to OFF menu working fine

if i turn it to ON menu not working, so i turned it to OFF… that solved the issue with menu