Change video player resolution


#1

Hello :grinning:

I have embeded a youtube video with the following dimensions: height=“478.8” width="576" I like those dimensions because it looks good. The problem is that when I play it the resolution is 360p (the authomatic youtube player resolution). I want it to be 720p every time I play it without having to change it manually from 360p to 720p. This is the code. Could somenoe please check and modify it to set the player to 720p resolution instead of 360p resolution?

<div class="separator" style="clear: both; text-align: center;">
<br /></div>
<div class="separator" style="clear: both; text-align: center;">
<iframe allowfullscreen="" class="YOUTUBE-iframe-video" data-thumbnail-src="https://i.ytimg.com/vi/2QFBZgAZx7g/0.jpg" frameborder="0" height="478.8" src="https://www.youtube.com/embed/2QFBZgAZx7g?feature=player_embedded" width="576"></iframe></div>
<br />

This is 360p (authomatic)

This what I want (720p)

Thank you


#2

Youtube applies video quality automatically according to user’s browsing speed. I think it will show HD only when you or your visitor has enough speed to watch at this quality.

If you want to show 720p quality then just add ?vq=hd720 parameter after the iframe url.

So your full code will be -

<div class="separator" style="clear: both; text-align: center;">
<br /></div>
<div class="separator" style="clear: both; text-align: center;">
<iframe allowfullscreen="" class="YOUTUBE-iframe-video" data-thumbnail-src="https://i.ytimg.com/vi/2QFBZgAZx7g/0.jpg" frameborder="0" height="478.8" src="https://www.youtube.com/embed/2QFBZgAZx7g?feature=player_embedded?vq=hd720" width="576"></iframe></div>
<br />

Thanks :slight_smile:


#3

Thanks for your response.

Unfortunately when I add ?vq=hd720 it doesn´t change to 720p resolution, it´s still 360p. I have highspeed internet so browsing speed is not the problem. Is there any other possibility?

Thanks for your attention :grinning:


#4

Can someone help me? When I add ?vq=hd720 it doesn´t change to 720p resolution, it´s still 360p. I have highspeed internet so browsing speed is not the problem. Is there any other possibility? :cry:


#5

Try adding ?rel=0 to the url again and tell me if it works or not. :slight_smile:


#6

When I add ?rel=0 it doesn´t change to 720p resolution, it´s still 360p. Anyway, thanks for your attention