Blogger now Introduced Https security to blogger blogs!


#1

Recently in the buzz section of blogger, I found that now we can use https for our blogger blog.Google’s mission of expanding internet security from gmail to adsense is now carry forwarded to blogger.We can access this feature now only on blogger blogspot domains not on custom domain.I think google still has plans to introduce it to custom domains.

For enabling this feature you must :-

  1. Use a blogspot domain.
  2. You shall go to to settings in your blogger blog.
  3. Then enable it by looking into the picture

I would like to see your reactions on this action taken by blogger.


#2

Well, @Nafees, I don’t think it is much beneficial for us.

Here’s why: 3 Reasons Why Blogger’s New Feature, Not Good For Bloggers This Time

Lets see what other feels about it :kissing:


#3

It’s 50-50 :slight_smile: There are advantages and disadvantages but i’m very thankful for blogger for moving one step ahead in blogger security :slight_smile:


#4

Nothing happens on my blog after I enable it :disappointed_relieved:


#5

Open You Blog By just adding https:// in front of url and then you will see the secured icon will come :smile:

Like this-

https://yourblogurl.blogpot.com


#6

Buddy, You should checkout this

googleonlinesecurity.blogspot.com, it’s redirecting very well for me.

For custom domain, Cloudflare is working for me.

When you mix any of non ssl content with ssl site, then obviously, you will see yellow icon in address bar, no matter which platform and which sites you are using.

Hope it helps to edit your article :smile:


#7

I can say that your second point:

could be correct but your first post is wrong. May be, google’s blog is redirecting but not all blogs. Google has written too in Blogger blog:

Once enabled, your blog will become accessible over both HTTP andHTTPS connections. Blogspot authors should be aware that if they choose to encrypt at this time, some of the current functionality of their blog may not work over HTTPS. This can be a result of template, gadgets, and blog post content, and is often caused by mixed content errors, some of which may be fixable by the author themselves.


#8

First of I never reply on any topic without correct analysis, so please before say anything to me, first analysis and research yourself.

Here you can see right now, two official google blogger using ssl.

Reference - http://buzz.blogger.com/2015/09/https-support-coming-to-blogspot.html

Read out 7th paragragh from above link.

When you mention any of non-ssl content on any ssl sites, then obviously browser display yellow icon or mixing content error, Here is another reference for that, it is specially created for blogger- https://support.google.com/blogger/answer/6286127?hl=en


#9

You can visit my blog. I have enabled https from my blog’s setting. It is available over both HTTP and HTTPS connections. It is not redirecting me from http to https. If I visit it without adding http. So please do complete your research first.


#10

Yes @Arjunsinh_Chauhan I agree to shivansh. I also visited shivansh’s blog but its not getting https in its web address its only http. but if I specify https in url then hit enter it does show me the blog.


#11

Also shivansh over https I cannot see your twitter widget loading ??


#12

Oh! Thanks for reporting it. Just going to solve it. :smile:

Update: The issue has been solved.


#13

Nope its still the same! even in http its not coming


#14

Clear your browser catch and reload it would then appear I think.


#15

no its still not coming, same as screenshot :confused:


#16

They are working @Nafees. And what happened @Arjunsinh_Chauhan


#17

M not lying shivansh!

and what do you mean by “What happened?”


#18

Sorry brother, but looks like you have not using relative links(A links that automatically convert based on URL) in your blogger, just look out your about section, and related post.

I see it’s perfectly enable in your blog, but you have creating your own template, and that cause problem when I visit any tabs, so you need to use relative links.

Also, you have not change some http link to https, look your site source code.

Just let me know, this URL is redirecting to https or not?, http://googleonlinesecurity.blogspot.com

Here is another source for force SSL - http://stackoverflow.com/questions/4723213/detect-http-or-https-then-force-https-in-javascript


#19

yes brother it is. Still cant figure out proper details on this matter. MBT is also not active from 20+ days :confused:


#20

Don’t worry. It will be active. Actually Mohammad is too busy these days and soon he is going to start a series about JSON. I said what happened because he was cot replying.

Arjun, let me do some research about it.