Avoid landing page redirects for mobil page


#1

When I check my page on google page speed tools, I am getting the following error. :

Avoid landing page redirects Your page has 2 redirects. Redirects introduce additional delays before the page can be loaded.

www.sitename.com/ 
www.sitename.com/?m=1
www.sitename.com/?m=0

Do you think it is a problem ? Which url is correct m=1 or m=0 ?? I am really confused. Could you help me ?


#2

Disable Mobile Template in your template section. You are getting this error because you have enabled Mobile theme on devices such as smartphones and tablets. In order to avoid redirecting users to the mobile view you may go to Template section and then click the gear icon and select “No. Show desktop template on mobile devices.”

This will fix the redirects and delay issue :dizzy:


#3

Mohammad thanks for reply but I had already done it. “No. Show desktop template on mobile devices


#4

If you have done it then you may avoid the pagespeed insights because such redirects can not delay the speed unless you have a site as big as wikipedia!


#5

i have a small blogger https://www.javainterviewsolution.in just like 20 pages,so here i have done “No. Show desktop template on mobile devices” such type of setting,after that i am getting below this error… Your page has 2 redirects. Redirects introduce additional delays before the page can be loaded.